After additional monitoring, we consider this fully resolved. Employees may continue using the Employee Portal a normal.
Posted Nov 25, 2025 - 09:32 PST
Monitoring
The solution is in place, and after testing we consider this challenge resolved. Employees are once again able to sign into the employee portal and use the tools within. We will continue to monitor the fix, to ensure it remains stable as more people sign in.
Next update: By 10 AM, Tuesday, November 24,
Posted Nov 24, 2025 - 15:38 PST
Identified
Our vendor has a solution ready, and will be installing the fix shortly. Once installed, our technicians will run several tests with the vendor.
Please remain signed out of the Employee Portal.
Estimated Resolution: Unknown. Next Update: By 3:30 PM, today.
Posted Nov 24, 2025 - 12:42 PST
Investigating
This morning Employees may find they cannot access the Employee Portal. Those that can sign in may receive errors when trying to use its related systems and tools. (eg. Finance or HR information systems) We are asking employees to please sign out of the Employee Portal, while our vendor works on a solution.
Estimated resolution time: Unknown. Next update: By 1 PM today.
Posted Nov 24, 2025 - 09:52 PST
This incident affected: Administrative Systems (Employee Portal (FRIS, HRIS, Payroll, Etc)).