Microsoft reports that they have restored services: "We’ve confirmed that the affected infrastructure has returned to a healthy state and is operating as expected. We’ll continue to closely monitor the remediation actions taken and make any necessary adjustments to maintain stability. If users experience any residual issues, clearing local DNS caches or temporarily lowering DNS TTL values may help ensure a quicker remediation."
Posted Jan 23, 2026 - 09:17 PST
Update
Microsoft reports that their load balancing efforts had unintentional side effects. Causing some additional challenges. They are continuing to work on resolving these challenges. More information can be found at https://status.cloud.microsoft.
Posted Jan 22, 2026 - 15:43 PST
Update
Update from Microsoft: We're rebalancing traffic across all affected infrastructure to ensure the environment enters into a balanced state. We’re proceeding as quickly as possible and this approach will help us identify any additional actions needed for recovery. More info can be found at https://status.cloud.microsoft
Posted Jan 22, 2026 - 14:26 PST
Update
Update from Microsoft: While we've restored the affected infrastructure to a heathy state, further load balancing is required to mitigate impact. We're directing traffic to alternate infrastructure to achieve recovery. More information can be found at https://status.cloud.microsoft.
Posted Jan 22, 2026 - 13:50 PST
Identified
Microsoft is currently experiencing a challenge with their M365 suite of products and Exchange Online email service. This can impact everything from creating a new Teams chat to not being able to send/receive email. However it appears be inconsistent with it's service interruptions. What worked 5 minutes ago, no longer working and vise versa.