Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2025 - 06:00 PST
Scheduled
What is impacted: Technicians are installing security certificate updates to our wireless networks across all sites and campuses. (VIU-Secure, VIU-Guest, and Eduroam) Level of impact: During the maintenance window, connected devices may disconnect from our wireless networks. The first time you reconnect your device may prompt you to accept/trust the new security certificate before resuming your connection. Timing: Thursday, November 27, 6 AM. Preparation: After 6 AM, please take a moment to confirm you are still connected to VIU-Secure. If not, be sure to reconnect and accept/trust the new certificate.
Posted Nov 26, 2025 - 13:57 PST
This scheduled maintenance affected: Network: Internet, Wireless, and Wired.