Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2026 - 18:00 PDT
Scheduled
What is impacted: We are deploying a significant Windows Security update. This update replaces key security files that are set to expire on June 26, 2026. Level of impact: Device Restart Required; This update deploys in the background, and requires multiple restarts to complete. It will not force you to restart your device. We recommend saving your work and restarting your device once a week between now and June 26. Timing: Thursday, April 30, beginning at 6 pm. Continuing until all devices are updated. Preparation: You may find a particular day or time works best with your workflow for restarting your device. We suggest setting a weekly calendar reminder for that time, so it doesn't get lost in the shuffle.
Posted Apr 29, 2026 - 12:24 PDT
This scheduled maintenance affected: Computer Accounts and Files.