Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2023 - 06:00 PDT
Scheduled
What is impacted: Our internet provider is performing maintenance on some of their equipment. Level of impact: No interruption. VIU is not in the list of impacted sites, and should see no service interruption. Timing: 6am to 7am, Sunday, May 28. Preparation: None required.
Posted May 25, 2023 - 13:46 PDT
This scheduled maintenance affected: Network: Internet, Wireless, and Wired.