Employees are unable to access the Scheduling and Workload System

Resolved

A solution is now in place. Employees with the appropriate access should once again be able to sign into the Scheduling and Workload System.
Posted Feb 25, 2026 - 15:35 PST

Update

Our technicians continue their investigation to this challenge.

Estimated resolution time: Unknown.
Next update: by 4:30 pm today.
Posted Feb 25, 2026 - 13:55 PST

Investigating

We have received reports that employees are unable to access the Scheduling and Workload System.

Our team is currently investigating this challenge.

Estimated resolution time: Unknown.
Next update: by 2pm today.
Posted Feb 25, 2026 - 12:33 PST