Employees are unable to sign into the Employee Portal

Resolved

After additional monitoring, this is now resolved.
Posted Jun 30, 2026 - 09:29 PDT

Monitoring

Around 4:45 pm Friday, June 27, a challenge arose preventing employees from signing in to the Employee Portal.

After some initial testing, it was determined that the challenge lay with our vendors systems. We reached out and notified them of the issue.

The vendor has reported that this challenge is now resolved, As of 4:42 am, Monday, June 29, employees were once again able to sign into the Employee Portal. If you are still experiencing access issues, we recommend clearing browser cache and then attempting to access the system again.

We will continue monitoring to ensure everything remains stable.

Next update: 3:30 pm, Monday, June 29.
Posted Jun 29, 2026 - 10:04 PDT
This incident affected: Administrative Systems (Employee Portal (FRIS, HRIS, Payroll, Etc)).