Microsoft confirms that a recently deployed fix has resolved the issue.
Teams Calling for numbers with an auto-attendant or call queue are processing calls normally.
Posted Mar 03, 2025 - 13:10 PST
Identified
Microsoft has identified the potential source of the Teams Calling challenge. They have deployed a fix that should resolve the issue.
Summary: A Microsoft challenge has resulted in many of VIU's external facing phone numbers unable to receive phone calls. When calling impacted phone numbers the call ends once dialing is complete. These numbers include the main VIU number, Registration, Facilities, Security, and the IT Service Desk amongst several others.
Estimated resolution time: 1:30pm Next update: Today by 1:30pm.
Posted Mar 03, 2025 - 11:51 PST
Investigating
Microsoft is currently experiencing challenges with calls to and from select Teams phone numbers. Impacted numbers are ones set up with either: - An auto-attendant (e.g. Press one for x-person, press two for Y-option, etc..) - A call queue (one phone line taking multiple calls via many agents)
As a result, many of our external facing phone numbers cannot receive phone calls. When calling impacted phone numbers the call ends once dialing is complete. These numbers include the main VIU number, Registration, Facilities, Security, and the IT Service Desk amongst several others.
Microsoft technicians are investigating.
If you are calling into a VIU phoneline and it is not going through, please watch this space. Once Microsoft has resolved this issue, we will post an update here. In the interim, if you need to reach the IT Service Desk please use our toll-free number.
Estimated resolution time: Unknown Next update: Today by 12pm.