VIU computer printing challenge impacting employees and students at all sites and campus
Resolved
This incident has been resolved. If you are unable to print, please try restarting your computer and try printing again.
Posted Oct 13, 2021 - 16:40 PDT
Monitoring
Technicians have deployed a fix and we are monitoring the results. If you are still unable to print, please restart your computer and try again.

Next update: 4:15pm today
Posted Oct 13, 2021 - 10:49 PDT
Investigating
Employees and students may be unable to print to VIU printers.

Technicians are investigating.

ETA: Unknown

Next update: 10:45am today
Posted Oct 13, 2021 - 09:37 PDT
This incident affected: Printing.