Managed Print challenges impacting both employee and student printing.
Resolved
This is now resolved.
Posted Jan 20, 2025 - 16:37 PST
Monitoring
A solution has been deployed and this challenge has been resolved.

We will continue to closely monitor the fix, to ensure everything's rock solid.

Next update will be by 4:30 today.
Posted Jan 20, 2025 - 15:32 PST
Investigating
A challenge with our Managed Print system is causing printers to not print documents that have been released for printing.

The print job will appear in the queue on the Printer Server, and appear ready to print when signed into the printer. Once you select print, the print job disappears but the printer fails to print it out.

Please be sure to save copies of any documents you might need to print. If you can postpone your printing, please do so. There is no guarantee your print job will successfully print at the moment.

Estimated Resolution Time: Unknown.
Next update will be by 4:30pm today.
Posted Jan 20, 2025 - 15:22 PST
This incident affected: Printing.