Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2026 - 09:00 PDT
Scheduled
What is impacted: Our applications team are deploying semi-weekly updates to the following tools/applications: - Building Inventory System (BIS) - Key Request application - Lockers application Level of impact: No Interruption. These updates will occur in the background and should not interrupt your work. Timing: 9 am to 5 pm, every Tuesday and Thursday. Preparation: None
Posted Apr 08, 2026 - 13:57 PDT
This scheduled maintenance affected: Websites and Learning Tools (Library Services, University Website (viu.ca)).