This incident is now resolved. Our Vendor has restored stable internet and network service to VIU. They will continue monitoring, to ensure everything remains stable.
Posted Nov 05, 2025 - 10:49 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 05, 2025 - 08:50 PST
Identified
VIU’s internet provider is currently experiencing service issues that are impacting network and internet access.
All campuses have limited network and internet access. Some VIU websites and services will be unavailable. VPN may not be available.