After monitoring, Papercut access remains stable. This incident is now resolved.
Posted May 14, 2025 - 14:52 PDT
Monitoring
A solution is in place, and the Papercut Web Portal is back online. Technicians will keep a close eye on the portal, to ensure it remains stable.
Next update: 3:30pm, today.
Posted May 14, 2025 - 12:53 PDT
Investigating
Employees and students may be unable to access the Papercut web portal, or print from some devices. The web portal appears to be down for all users. This means individuals are unable to add funds to their account.
Our technicians are currently investigating.
Estimated resolution time: Unknown. Next update: 2:30pm, today.