Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 19, 2025 - 09:25 PST
Scheduled
What is impacted: Student Record System; We need to put the Student Record System into maintenance mode to adjust some changes from last night's updates. Level of impact: Service Interruption. Students and employees will not be able to access the Student Record System during the maintenance window. Timing: 9:20 AM to 10:10 AM, Friday, December 18. Preparation: < /b>None.
Posted Dec 19, 2025 - 09:24 PST
This scheduled maintenance affected: Administrative Systems (Student Records (SRS)) and Student Self-service: My Student Record.