Adobe License Notice impacting VIU devices

Identified

This challenge is now impacting a number of institutions across BC.

Adobe is investigating.

Next update: Tuesday, September 1, at 5:30 pm.
Posted Aug 31, 2026 - 12:08 PDT

Monitoring

When opening Adobe products on VIU devices, a pop-up appears. It warns that the Adobe license has expired, and that you can still use the software for a few days.

Adobe has confirmed that this should be fixed before the end of the day tomorrow.

Estimated resolution time: Before Tuesday, September 1, at 4:30 pm.
Next update: Tuesday, September 1, at 5:30 pm.
Posted Aug 31, 2026 - 11:13 PDT