Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 09:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 17, 2025 - 14:43 PST
Scheduled
What is impacted: Our Web team is migrating the adm.viu.ca website to a newer version of our Drupal Web Content Management System. Level of impact: No Interruption. Access to adm.viu.ca will remain uninterrupted during the move. Editors may need support from the Brand and Marketing team when connecting to their sites for content editing for the first time. Timing: 9 AM to 5 PM, Thursday, December 18. Preparation: None.