Microsoft Incident: Possible delays in sending and receiving email.
Resolved
Microsoft Technicians identified a recent update to their Canadian infrastructure as the probable source of this issue.
Rolling back this update has successfully restored normal email delivery times.

Microsoft considers this challenge to be resolved.
Posted Apr 17, 2024 - 13:58 PDT
Identified
Microsoft has identified a recent update to their Canadian infrastructure that may be contributing to this issue. They are in the process of rolling back the update, as a potential remediation option.

Resolution time: Unknown.
Next update: 2:30pm, today.
Posted Apr 17, 2024 - 12:17 PDT
Investigating
Microsoft is currently experiencing challenges with their Exchange Online (EXO) email service. Inbound and outbound email messages may be intermittently delayed with any EXO mailbox. This includes all @viu.ca mailboxes.

Microsoft technicians are investigating.

Resolution time: Unknown.
Next update: 12:30pm, today.
Posted Apr 17, 2024 - 09:58 PDT
This incident affected: Email.