Power outage impacting employees and students at Powel River campus
Resolved
BC Hydro crews have restored power to the Powell River campus.
Posted Nov 22, 2021 - 13:01 PST
Investigating
VIU Powell River Campus has no power.

BC Hydro reports the power went down at 11:12am today. A work Crew has been dispatched to investigate.


Resolution time: unknown

Next update 1pm today
Posted Nov 22, 2021 - 11:50 PST